Updates to a multi-kiosk app are not automatically pushed to a device. The changes made are reflected in the Knox Manage console, but the Kiosk mode app on a device does not receive the update. If a new multi-app Kiosk is created, the updates are successfully applied, but future app updates do not work again.
[Cause]
[Cause]
By default, the Kiosk mode app does not update automatically. This is because when the Kiosk app is updated, it momentarily disables Kiosk mode. The auto update feature must be intentionally enabled by the admin.
[Resolution]
To push the updated app version, the Admin must enable the update kiosk app command. This can be found in the Knox Manage console under Device command > App management(Internal/Kiosk app) > Install > Select modified Kiosk app.
Knox Manage Kiosk Wizard update.
Knox version*: All
Model number: All
Android version: All
[Summary]