[Environment]
Knox Manage
[Summary]
The Location button is not activated on a device, even though the Location command has been sent (Device Command > Device confirmation > Location).
[Cause]
The Location button is only activated after following conditions are met.
1. The admin sends the location command. This calls the Knox API (startGPS) to turn on GPS.
2. The Android API successfully collects the location information. Knox Manage will try to obtain the location information up to 2 mins. If it fails to get the information, the location button is deactivated.
NOTE – This API only controls the GPS on/off function. Other locations method, such as WiFi and mobile networks, cannot be turned on with this API due to legal reasons.
NOTE - Check the location settings on the device you are trying to locate. The location setting should be set to High accuracy mode. GPS only mode may not be able to get location information if user's device is indoors.