[Environment]
SDS IAM & EMM
[Summary]
Device enrollment fails. An event is shown in the user portal activity logs indicating the reason as "MaxLimitReached". On device side you also get an error about an Enrollment Failure.
[Cause]
This can happen due to the policy set that limits the maximum number of devices that a user can enroll.
This policy is available since version 17.11 release and can be found under: Endpoint Policies > Device Enrollment Settings > Max number of devices a user can enroll (default 20)
The default limit is set to 20 devices. You can specify the maximum number of enrolled devices with the same account when a new device is enrolled. Maximum number is 1000.
- The default the limit is set to 20 devices but you can control it to up until 1000 devices from the policy.
- If you already have more than the max number of devices enrolled for a given user you will not experience any issues with devices that are already enrolled, but they will be limited from enrolling more devices.
- This limit can be raised on a per-tenant basis. Please create a BTSP ticket to increase the limitation. (Official recommendation from tech team is not to raise this limit above 5,000 devices)
Below are the indications you will see when this limit is reached.
On device side:
On user activity logs (console side) :
[Resolution]
Adjust the policy Endpoint Policies > Device Enrollment Settings > Max number of devices a user can enroll (default 20) to your needs in order to allow enrollment.
For more details, please see the online Samsung SDS IAM & EMM Administrator’s Guide available here or by clicking the ? button in the upper right had hand corner of the admin portal Samsung SDS IAM & EMM console.