Environment:
- Product: Knox Configure (KC)
- Knox version*: 2.7
- Model number: SM-G532
- Android version: 6 (Marshmallow)
NOTE: Android 7 (Nougat) running Knox version 2.7.1 and above is the minimum Android version KC fully supports.
Overview:
When enrolling an SM-G532 device using a ProKiosk profile, the KC client crashes with a “Unfortunately, KC Client has stopped” error message.
Cause:
This error is related to the following dumpstate log sample:
08-09 13:57:15.332 7170 7243 E AndroidRuntime: FATAL EXCEPTION: IntentService[JSONIntentService]
08-09 13:57:15.332 7170 7243 E AndroidRuntime: Process: com.sec.knox.kccagent, PID: 7170
08-09 13:57:15.332 7170 7243 E AndroidRuntime: java.lang.NoClassDefFoundError: Failed resolution of: Lcom/samsung/android/feature/SemFloatingFeature;
The SemFloatingFeature instance is null, which returns an exception in the API isDexSupported().
Resolution:
To address this issue, a try catch was added to the isDexSupported() API. The exception is now handled when the SemFloatingFeature instance is null.
KC supports Android 7 (Nougat) with Knox version 2.7.1 and above. Unfortunately, the Samsung Knox team cannot guarantee KC’s compatibility with devices running lower Android/Knox versions.