Environment
- Knox Configure (KC) for Wearables
Overview
In KC, after a device is configured on a profile with a SSID name and password specified in Profiles > device profile > Device connectivity > Network (optional), the password is not properly pushed to the device if it is updated. The wearable device is then unable to connect to the Wi-Fi network specified in the profile.
Cause
The API used to determine if the Wi-Fi settings need a new password incorrectly returns "false" if the SSID and Password configuration was previously saved. The incorrect value is returned even if the password has been changed.
Resolution
The Samsung Knox team is currently working on a fix for the API logic.
Workaround
In the KC console, under Profiles > device profile > Device connectivity, use Advanced Wi-Fi Settings when specifying an SSID Name and password for a device instead of entering it under Network (optional).