Environment
- Knox Mobile Enrollment (KME)
Overview
In KME, some users are encountering the following error when assigning a profile to a device:
Your access to this service has been blocked.
Cause
The user's account is missing the necessary permissions in KME.
Resolution
Only the Super Admin can check or change the permissions assigned to a role unless other admins are also given the permission to view user roles. In KME, under Administrators & Roles, check that the role that the user is assigned to has the following permissions selected:
-
Devices and Uploads:
Manage Devices
Assign Profile
Unassign Profile
Manage Tag
-
Device users:
Manage Device User
Add, edit, assign and unassign
To add a new administrator and manage their roles, see the KME documentation on how to invite and manage admins.
Additional information
To learn more about how KME handles admin permissions, see Role-based access control (RBAC).