Environment
- Knox Platform for Enterprise (KPE)
- Samsung Calendar
- Microsoft Exchange ActiveSync 16
Overview
Some users are experiencing issues when opening an attachment in a Knox Workspace calendar event and viewing it. The attachment appears in the Knox Workspace container, but cannot be opened. The issue is observed in the following instances:
- Receive a meeting invitation with an attachment
- Open a meeting in Samsung Calendar
Cause
The calendar is unable to process the attachment's Universal Resource Identifier (URI).
time=2019-12-10 16:43:27 thread=10998 cmd=ItemOperations fileRef=16%3aE%3aAAMkAGNlZjlkMDkyLTcxYTktNDA4Ny1iNzUzLTQ5MzVlYTIyZDcxMABGAAAAAAATQqsxtuQ8TJQRbtCwXCQIBwATb8ShkoPaQaw2EintJaHtAAAAAAENAAATb8ShkoPaQaw2EintJaHtAAEZuk40AAA%3d%3aARIAEAA6wagLWbU1SZ7WDWAyz%2bGB FileNameFileAttachment.pdf mAccount=AccountName time=2019-12-10 16:43:27 thread=10998 mAccount=Work_two cmd=ItemOperations attachmentId=2 FileName=FileAttachment.pdf res=200 responseTime=0.417sec time=2019-12-10 16:43:27 thread=10998 [Cal] accId=username@domain.com msgId=12 attachmentId=2 size=149315 FileName=Samsung - FileAttachment.pdf Exception:open failed: ENAMETOOLONG (File name too long)
Resolution
The Samsung Calendar team has identified a fix for this issue, which is scheduled to be deployed in an upcoming Android Q update.