Environment
- Knox Manage (KM)
- Android Enterprise (AE) Device Owner (DO) mode
- Knox Service Plugin (KSP)
Overview
When launching an app on a KM-managed device with KSP enabled, some users are receiving the following error:
Security policy prevents turning on device administrators
Cause
If KSP is enabled in the KM console, it will block any application requesting device admin permissions by default.
Resolution
This issue was addressed and fixed in the Knox Manage v20.2 release. You must add the app receiving the error in the device admin whitelist:
- In your KM console, select Profile.
- From the Samsung Knox Android Enterprise tab, select System > Whitelisted Device Admin policy.
- Select Apply, then Add the app receiving the error.
- Save and apply your changes.
Additional information
- For the full KM v20.2 release notes, see New Features in the KM (v20.2) Release - Feb. 27 2020.
- To learn more about how KSP works, see the KSP admin guide.