Environment
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Knox Manage
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Android Legacy
Overview
Some customers are experiencing an issue where they are unable to install an updated version of an internal app that has a different version code.
The following error appears in the Knox Manage agent:
Failed to install the app
Cause
An Android application uploaded to Knox Manage must have the same signature as the previous version, even if the version code is changed.
While the error does not appear in the Knox Manage console, it can be seen in the device dumpstate:
PackageManager: Package “name” signatures do not match previously installed version; ignoring!
Resolution
You must unassign the old APK file from the organization or group the device is assigned to, send the Uninstall App command to the device, then assign the updated APK file to the organization or group.
Additional information
For steps on how to assign applications in Knox Manage, see the Knox Manage admin guide.