Environment
- Knox Configure (KC)
- Knox Mobile Enrollment (KME)
- Knox Manage (KM) Device Owner (DO) mode
Overview
When a device is assigned a Knox Configure (KC) profile and a Knox Manage (KM) DO profile through Knox Mobile Enrollment (KME), the KC enrollment process freezes during the device's initial bootup.
Below is the enrollment flow that is observed:
- KME enrollment begins.
- KC is triggered.
- KM appears during KC enrollment.
- KM closes and returns to KC.
- KC freezes during enrollment.
Cause
Due to a KM logic error causing the KM agent to install twice, KC enrollment is interrupted.
Resolution
The Knox team is working to fix the logic in the KM agent.
Workaround
As a temporary workaround for this issue, follow the steps below:
- Restart the device.
- Pull down the KC profile again using one of two methods:
- On the device, go to Settings > About Device > Software Info > Knox Configure > Apply latest profile.
- In your browser, navigate to configure.samsungknox.com and select RE-ENROLL.
If you have not yet booted your device, you can prevent KC enrollment from freezing by keeping the device assigned in KME, but unassigning the device from KC.
Once the KME enrollment is complete, re-assign the device to the KC profile and configure the device by navigating to configure.samsungknox.com and selecting FIRST-TIME ENROLLMENT.
Additional information
- For steps on how to assign devices in KC, see the KC admin guide.
- For info about device owner support in KME, see the KME admin guide.